Problema con My Awards 1.2
Hola amigos!, vereis, ayer me suscribi a "http://www.mybbcentral.com" para conseguir varios plugins, y sobre todo el de "My Awards". Y bueno, me lo ...

Hola amigos!, vereis, ayer me suscribi a "http://www.mybbcentral.com" para conseguir varios plugins, y sobre todo el de "My Awards".

Y bueno, me lo instalo paso por paso como dice el readme, aunque como tengo el foro en español, los archivos que tenia que subir a la carpeta "“inc\languages\english”" los subi a "“inc\languages\espanol”.

Activo el plugin, me otorgo una medalla de prueba, hasta ahi todo bien, pero en mi perfil del foro, al pulsar sobre la medalla me sale esto:

http://modnationracer.es/myawards.php?awid=1

El problema creo que es que no se encuentra la ruta para el archivo "myawards.php" y no se que debo modificar... aun no soy muy bueno en PHP jajaja.

¿Me podeis ayudar por favor? T_T. Gracias de antemano!
¿MyAwards 1.2?
Eso es para la versión 1.2, y todos usamos(o eso creo) 1.4
(30 Aug, 2009, 3:02 am)Aeroxis escribió: ¿MyAwards 1.2?
Eso es para la versión 1.2, y todos usamos(o eso creo) 1.4

Es la ultima version del plugin My Awards, no la version de Mybb ^^
Yo tengo el MyAwards, y me funciona.
Cada archivo lo he subido en estos directorios, mira si los tuyos son los mismos:
Raiz del foro(htdocs) tengo MyAwards.php
En admin/modules/user/ subes myawards.php
En inc/languages/espanol/ myawards.lang.php
En inc/languages/espanol/admin/ user_myawards.lang.php
En inc/plugins/ my_awards.php
En images/medallas(awards/ todas las imágenes de las medallas.
(30 Aug, 2009, 4:01 am)Aeroxis escribió: Yo tengo el MyAwards, y me funciona.
Cada archivo lo he subido en estos directorios, mira si los tuyos son los mismos:
Raiz del foro(htdocs) tengo MyAwards.php
En admin/modules/user/ subes myawards.php
En inc/languages/espanol/ myawards.lang.php
En inc/languages/espanol/admin/ user_myawards.lang.php
En inc/plugins/ my_awards.php
En images/medallas(awards/ todas las imágenes de las medallas.

Lo tengo exactamente igual que tu, pero mira, he estado indagando mas en el tema, y en mi foro si me voy a mi perfil, miro una seccion que hay llamada "Awards" me sale que tengo una medalla y al lado pone [Details]. Pues bien si pulso ahi SI me sale los detalles, pero es por que me redirecciona a: "http://modnationracer.es/myawards.php?uid=1"

Ahora si le doy a la medalla directamente desde cualquier post mio, me redirecciona a: "http://modnationracer.es/myawards.php?awid=1"

Quizas es que no debe redireccionarme ahi ¿no? bua...ya no se que hacer, a ver seguire buscando mas cosas no se T_T
¡SOLUCIONADO!

Pero a ver es un problema del script creo yo... A ver como os explico, para todos aquellos que le pase lo mismo.

Yo tengo contratado un Host que lo contrate con el dominio "www.littlequest.com" y posteriormente añadi otro dominio "www.modnationracer.es".

Pues bien la raiz de mi Host se compone de las siguientes carpetas:

/c.panel
/demo
/public_ftp
/public_html
/modnationracer.es

Y algunas mas... pues bien, en la carpeta "public_html" tengo el portal Little Quest, y el foro en la carpeta "modnationracer.es". Pues bien el script llama a "myawards.php" que tiene que estar situada en la root principal, y no me reconoce la root principal del foro, sino del host, que es la carpeta "public_html". Y he tenido que poner el archivo "myawards.php" en la carpeta "public_html".

No se si me entendeis pero bueno, es una putada tener un archivo fuera de la root del foro, pero en fin, ya funciona que es lo importante.
Última modificación: 30 Aug, 2009, 4:22 am por Neski.
Tema solucionado, tema cerrado Wink!
Colaboradores
Aeroxis
This forum uses Lukasz Tkacz MyBB addons.