[Instalando]  Error 'Parse error' nada más empezar instalación
Hola, descargo desde la home el "mybb_1609_es_utf-8.zip" con la última versión en español, la descomprimo, entro con el navegador al directorio "Uplo...

Hola, descargo desde la home el "mybb_1609_es_utf-8.zip" con la última versión en español, la descomprimo, entro con el navegador al directorio "Upload/" y nada más entrar me aparece una página en blanco con el error:

"Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in ... Upload\inc\class_error.php on line 51"

Por lo que he buscado en la web, es bastante probable que se deba a que mi versión de PHP es la 4.4.4 (demasiado antigua, creo que se requiere al menos la 5), pero estoy buscando los requerimientos mínimos para instalar y ejecutar el MyBB y no los encuentro por ningún sitio, ni siquiera en la web inglesa oficial, ¿cuáles son dichos requerimientos, dónde puedo encontrarlos?

Un saludo...
Última modificación: 30 Jan, 2013, 2:21 pm por Z-Blue.
Bueno, te edito el titulo porque es demasiado largo y no me dejaba responderte Wink
En cuanto a tu consulta, los requisitos mínimos te aparecerán en el tercer paso de la instalación (justo después de aceptar los términos de la licencia)
Hola, pero si de inicio no los cumples, ¿cómo vas a llegar hasta el 3er paso, si no pasas ni del 1º? En fin, ¿cuáles son esos requisitos mínimos, pueden verse en algún sitio?
- - - Actualizado - - -
Bueno por fin he encontrado los misteriosos requerimientos:

http://docs.mybb.com/Requirements.html

Como se necesita PHP 5.1.0 o superior, me toca actualizar mi PHP 4, me ha tocado la china, a ver cómo me las apaño ahora con esto :-( ...
Última modificación: 30 Jan, 2013, 3:46 pm por Grid.
pues debes pedirle a tu hosting que actualice el php o ... cambiar de servidor Tongue
Hola, me lo estoy instalando (o intentando) en localhost. Un saludo...
Estupendo, cualquier cosa aqui estamos para intentar ayudarte
Pues sí que necesito ayuda, sí, esta mañana instalé Apache 2.2 con su programa instalador .msi y funcionó a la 1ª, intenté hacer lo mismo con el instalador del PHP 5.2 y me estoy volviendo loco con la puta instalación del PHP (como me temía, igual que me pasó hace años con el PHP 4), ¿dónde está la página de soporte en español para PHP, o algún foro PHP para poder preguntar mis dudas allí?

Gracias...
1ra no digas groserias, esta prohibido..

2da si ya instalaste apache actualizado ahora cual es el problema???... seguro que tienes el php encendido ??
En el instalador te dice los requerimientos
:)
Todo solucionado, aclararé el problema por si a alguien le pasa y lee este hilo:

Buscando en la web información sobre cómo instalar PHP 5, llegué a esta página:

http://www.websiteadministrator.com.au/a...hp533.html

Siguiendo sus pasos y su ejemplo, pretendí instalarme PHP con el instalador oficial .msi, descargado de su web. JAMÁS UTILICÉIS EL INSTALADOR para instalar PHP.

Repito, es fundamental: JAMÁS INSTALÉIS PHP CON SU "INSTALADOR". NO FUNCIONA, y provoca problemas con Apache dificilísimos de solucionar: que si no encuentra las DLL, que si no hay permisos...

Si llegáis hasta la página que os he dicho, CERRADLA INMEDIATAMENTE Y SALID HUYENDO.

Aunque en defensa de la web que tanto tiempo me hizo perder, tengo que decir que ella describe la instalación mediante el instalador de la última versión de PHP hasta el momento, la 5.3.3, mientras que yo me "instalé" la 5.2 (porque según esa web, para las versiones >= 5.3 en Windows XP se necesita tener el SP3, y yo solo tengo instalado el SP2), pero aún así, el proceso con el "instalador" no es ni mucho menos automático mientras que la instalación "a mano" es muy sencilla y se hace en pocos minutos.

También es cierto que esa web (en inglés) da información útil sobre los tipos de versiones PHP: VC6, VC9, las diferencias entre la instalación como módulo de Apache o como CGI... Esa información sí es buena, yo p.ej. seguí su consejos y no instalé PHP en la carpeta que el "instalador" propone por defecto (C:\Archivos de programa ... ), sino en la C:\PHP5 que me creé para ello.

A partir de aquí, que cada uno haga lo que quiera.

Ayer perdí casi todo el día desde por la mañana hasta por la noche intentando instalarme el PHP 5.2, con su instalador .msi, siguiendo los pasos de esa web; por la noche ya estaba con la cabeza loca intentando solucionar los innumerables mensajes de error que me daba Apache 2.2 al arrancarlo, hasta que a última hora, como último intento antes de acostarme, decidí probar la instalación "a mano", desinstalé todo lo anterior, y señores, siguiendo los sencillos pasos de esta página:

http://www.juanfelipe.net/node/39

Mano de santo, todo terminado en 5 minutos y funcionando perfectamente al 1er intento, bendito sea Dios, por fin terminó mi pesadilla, al navegar en local hasta http://localhost/phpinfo.php ya me aparece la tan ansiada pantalla repleta de información: PHP Version 5.2.17 , etc, etc...

Ahora cuando tenga tiempo ya podré ponerme con la instalación del MyBB en localhost, pero eso ya será otra historia :-) ...
Colaboradores
Sonrics papi Himura DARKNESSDH Cluster
This forum uses Lukasz Tkacz MyBB addons.