Ficons for Mybb 1.4x corregido
Esto esta adaptado de el tema Ficons for Mybb 14*! posteado por AlanB como en el otro tema Entramos en CP Admin/Platillas y Estilos/Plantillas/Tu t...

Esto esta adaptado de el tema Ficons for Mybb 14*! posteado por AlanB
como en el otro tema
Entramos en CP Admin/Platillas y Estilos/Plantillas/Tu tema Templates y en Caja del Foro - Plantillas hacemos clic en "forumbit_depth2_forum"

<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>

Añadir a Continuacion: (codigo modificado)
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" title="{$forum['name']}"/></td>

Quedando algo asi la plantilla luego de la edicion:
<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="45" height="45" title="{$forum['name']}"/></td><td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>

Ahora editamos la plantilla "forumbit_depth1_cat"...

Buscar:
<td class="thead" colspan="5">

Reemplazamos por:
<td class="thead" colspan="6">

Siempre busquen el mismo modelo:
<td class="tcat" colspan="2"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>

Reemplazar por:
<td class="tcat" colspan="3"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>

Quedando algo asi la plantilla luego de la edicion:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<thead>
<tr>
<td class="thead" colspan="6">
<div class="expcolimage"><img src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div><strong><a href="{$forum_url}">{$forum['name']}</a></strong><br /><div class="smalltext">{$forum['description']}</div></div>
</td>
</tr>
</thead>
<tbody style="{$expdisplay}" id="cat_{$forum['fid']}_e">
<tr>
<td class="tcat" colspan="3"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="85" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_threads}</strong></span></td>
<td class="tcat" width="85" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_posts}</strong></span></td>
<td class="tcat" width="200" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
</tr>
{$sub_forums}
</tbody>
</table>
<br />

Para los subforos para evitar el problema de deformidad

Modificar la plantilla "forumdisplay_subforums"
en CP Admin/Platillas y Estilos/Plantillas/Tu tema Templates y Mostrar Foro - Plantillas "forumdisplay_subforums"

Buscar:
<td class="thead" colspan="5" align="center"><strong>{$lang->sub_forums_in}</strong></td>

Reemplazar por:

<td class="thead" colspan="6" align="center"><strong>{$lang->sub_forums_in}</strong></td>

Por ultimo...

Buscar: (y repetirlo)
<td class="tcat" width="2%">&nbsp;</td>

Quedando algo asi la plantilla luego de la edicion:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead" colspan="6" align="center"><strong>{$lang->sub_forums_in}</strong></td>
</tr>
<tr>
<td class="tcat" width="2%">&nbsp;</td><td class="tcat" width="2%">&nbsp;</td>
<td class="tcat" width="59%"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="7%" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_threads}</strong></span></td>
<td class="tcat" width="7%" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_posts}</strong></span></td>
<td class="tcat" width="15%" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
</tr>
{$forums}
</table>
<br />

Aclaracion el codigo para los iconos es {$theme['imgdir']}/ficons/icon_{$forum['fid']}.png
{$theme['imgdir']}= la carpeta de imagenes de su tema (/images/mytema)
crear una carpeta con el nombre ficons, (si no quieres esata parte deves modificar el codigo para no usar la carpeta,
icon_{$forum['fid']}.png= como antes el nombre para la imagen es el mismo
http://www.nuestro-sitio.com/forum/forumdisplay.php?fid=5
entonces nuestro icono informativo correspondiente seria "icon_5"
la extencio la puse en png, porque me gusta mas ademas la mayoria de los pack de iconos bienen en esa extencion

Cree otro tema porque el otro esta saturadicimo,
oie pprad una duda men,
tengo el ficons este k pusiste
pero kiero poner un icono de 32x32
y lo agranda
como le hAgo para achicarlo
esque mira:
[Imagen: kdlpo6.jpg]
http://i50.tinypic.com/kdlpo6.jpg

Las imagenes chicas son las que subi, y el ficons las agranda

Edito:
creo que encontre el error
<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="45" height="45" title="{$forum['name']}"/></td><td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>


solo remplazo este code
<img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="45" height="45" title="{$forum['name']}"/>

por
<img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="32" height="32" title="{$forum['name']}"/>
No?


ya no, ya lo arregle solo =P
Silver
6 Dec, 2009, 10:14 amSilver escribió:
oie pprad una duda men,
tengo el ficons este k pusiste
pero kiero poner un icono de 32x32
y lo agranda
como le hAgo para achicarlo
esque mira:
[Imagen: http://i50.tinypic.com/kdlpo6.jpg]
http://i50.tinypic.com/kdlpo6.jpg

Las imagenes chicas son las que subi, y el ficons las agranda

Edito:
creo que encontre el error
<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="45" height="45" title="{$forum['name']}"/></td><td class="{$bgcolor}" valign="top">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" valign="top" align="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
<td class="{$bgcolor}" valign="top" align="right" style="white-space: nowrap">{$lastpost}</td>
</tr>


solo remplazo este code
<img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="45" height="45" title="{$forum['name']}"/>

por
<img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="32" height="32" title="{$forum['name']}"/>
No?


ya no, ya lo arregle solo =P

mira si, el problema es que cundo ise ese codigo tenia imagenes mas grandes y las redimensione en el script, mira en el codigo que puse esta esta parte widith="45" height="45" que debes quitar o colocar la dimension de tus iconos, te serviria si tienes varios iconos diferentes y no quieres editarlos uno por uno solo, si no pos solo quita esa parte,
el codigo quedaria asi
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" title="{$forum['name']}"/></td>
Saludos y Gracias por avizar, se me olvido sacarlo, jejeje.
lo hise tal cual pero en explorer se ven todos desordenados los foros y subforos, en firefox se ve bien

por que sea que se ve feo en explorer?
sierto el internet explorer muestra las celdas del ficons y del nombre del foro como si fueran una solo nose por que pase espero revisar el codigo te aviso si veo algo mal, saludos
Himura
26 Dec, 2009, 7:08 pmHimura escribió:
sierto el internet explorer muestra las celdas del ficons y del nombre del foro como si fueran una solo nose por que pase espero revisar el codigo te aviso si veo algo mal, saludos

alguna novedad? por que muchos usan explorer y pues ya tuve que poner un aviso de que no lo usen por que se ve mal
Chava hermano mira estube probando en mi casa y funciona bien para ie seguro que segiste todo como te deje??
usas el tema funky fresh no??
mira te dejare las plantillas comolas puse.

forumbit_depth2_forum

<tr>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/{$lightbulb['folder']}.gif" alt="{$lightbulb['altonoff']}" title="{$lightbulb['altonoff']}" class="ajax_mark_read" id="mark_read_{$forum['fid']}" /></td>
<td class="{$bgcolor}" align="center" valign="top" width="1"><img src="{$theme['imgdir']}/ficons/icon_{$forum['fid']}.png" widith="32" height="32" title="{$forum['name']}"/></td>
<td class="{$bgcolor}" valign="top" valign="center">
<strong><a href="{$forum_url}">{$forum['name']}</a></strong>{$forum_viewers_text}<div class="smalltext">{$forum['description']}{$modlist}{$subforums}</div>
</td>
<td class="{$bgcolor}" align="center" valign="center" style="white-space: nowrap">{$lastpost}</td>
<td class="{$bgcolor}" align="center" valign="center" style="white-space: nowrap">{$threads}{$unapproved['unapproved_threads']}</td>
<td class="{$bgcolor}" align="center" valign="center" style="white-space: nowrap">{$posts}{$unapproved['unapproved_posts']}</td>
</tr>

forumbit_depth1_cat

<table cellpadding="0" cellspacing="0" width="100%">
<tr>
<td><img src="{$theme['imgdir']}/thead_l.gif"></td>
<td class="thead" colspan="6">
<div class="expcolimage"><img src="{$theme['imgdir']}/{$expcolimage}" id="cat_{$forum['fid']}_img" class="expander" alt="{$expaltext}" title="{$expaltext}" /></div>
<div class="th"><strong><a href="{$forum_url}" title="{$forum['description']}">{$forum['name']}</a></strong></div>
</td>
<td><img src="{$theme['imgdir']}/thead_r.gif"></td>
</tr>
</table>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tbody style="{$expdisplay}" id="cat_{$forum['fid']}_e">
<tr>
<td class="tcat" colspan="3"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="190" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
<td class="tcat" width="70" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_threads}</strong></span></td>
<td class="tcat" width="70" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_posts}</strong></span></td>
</tr>
{$sub_forums}
</tbody>
</table>
<br />

forumdisplay_subforums

<table cellpadding="0" cellspacing="0" width="100%">
<tr>
<td><img src="{$theme['imgdir']}/thead_l.gif"></td>
<td class="thead" colspan="6"><div class="tf"><strong>{$lang->sub_forums_in}</strong></div></td>
<td><img src="{$theme['imgdir']}/thead_r.gif"></td>
</tr>
</table>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<td class="tcat" width="2%">&nbsp;</td>
<td class="tcat" width="2%">&nbsp;</td>
<td class="tcat" width="59%"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="7%" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_threads}</strong></span></td>
<td class="tcat" width="7%" align="center" style="white-space: nowrap"><span class="smalltext"><strong>{$lang->forumbit_posts}</strong></span></td>
<td class="tcat" width="15%" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
</tr>
{$forums}
</table>
<br />

si no te resulta tambien te dejo un xml del tema con la modificacion incluida
[attachment=190]
ya man gracias, con esas plantillas si se ve bien, esque nunca entendi bien el tuto entonces le hise mas o menos a mi criterio y eran totalmente diferentes mis plantillas y esas que pusiste

pero ya quedo grax
[font=Verdana]Solo para decir que en mi foro tengo un 2 temas, en el default mio si funsiono perfectamente, pero en el otro Mybb Pro no existe la linea:
<td class="tcat" width="2%">&nbsp;</td>

Entonces tienes que crearlaWink

Quedo algo asi:
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead" colspan="6"><strong>{$lang->sub_forums_in}</strong></td>
</tr>
<tr>
<td class="tcat" width="2%">&nbsp;</td>
<td class="tcat" colspan="2"><span class="smalltext"><strong>{$lang->forumbit_forum}</strong></span></td>
<td class="tcat" width="150" align="center"><span class="smalltext"><strong>{$lang->forumbit_lastpost}</strong></span></td>
</tr>
{$forums}
</table>
<br />

Solo por si pasa con otros temas.
[/font]
Omar G.
eso bueno si colocaste bien el codiigo no deverias tener problemas con ese icono, tiene que estar donde siempre en images/tutema
on.gif = nuevos mensajes
off.gif = sin nuevos mensajes
offlock.gif = cerrado
Colaboradores
vacoweb TheZeuS stuka Silver sergio98 Paansho Omar G. Niqito.- Nancudur Kaiohh K3NS4N Hopper Gypaete Gmaster DarkFinder Cluster Chava cacacolass
This forum uses Lukasz Tkacz MyBB addons.