estas usando una traducción obsoleta diseñada para MyBB 1.4.x, tienes que usar la de MyBB 1.6.8
:)
yo no veo ninguna anormalidad en ese sector de tu foro
Colaboradores
papi Cluster
This forum uses Lukasz Tkacz MyBB addons.