Ayuda con este código
Pues quería hacer una guía pero me lío con el siguiente código... el de poner listas con viñetas. Lo que quería era poner dentro de una viñeta, otra...

Pues quería hacer una guía pero me lío con el siguiente código... el de poner listas con viñetas.
Lo que quería era poner dentro de una viñeta, otra... Pero como no sabía, lo hice con html y lo que pasa es que al terminarlo y querer poner una viñeta fuera, me aparece dentro...
Alguien me podría pasar el código? :S mira, os djeo como lo tengo y como me sale:

<A href="#Armas principales">
<ul>
<li>Armas principales</A>
   <ul>
   <A href="#Subfusiles">
   <li>Subfusiles</li></A>
   <A href="#Fusiles de asalto">
   <li>Fusiles de asalto</li></A>
   <A href="#Escopetas">
   <li>Escopetas</li></A>
   <A href="#Ametralladoras ligeras">
   <li>Ametralladoras ligeras</li></A>
   <A href="#Fusiles de precisión">
   <li>Fusiles de precisión</li></A>
   </ul>
</li>


<A href="#Armas secundarias">
<ul>
<li>Armas secundarias</A>
   <ul>
   <A href="#Pistolas">
   <li>Pistolas</li></A>
   <A href="#Lanzacohetes">
   <li>Lanzacohetes</li></A>
   <A href="#Especiales">
   <li>Especiales</li></A>
   </ul>
</li>

<A name="Armas principales"><H1>Armas principales</H1></A>


<A name="Subfusiles"><H1>Subfusiles</H1></A>
Etcétera con la información
Lo siento si os liáis, es que también inserto el code para poner un link dentro de la misma página...

Por si no me expliqué bien:
Me aparece así:
* Lo que sea
.   * Dentro de lo que sea
.   * Dentro de lo que sea

* * Lo pongo como ''Lo que sea'' pero me aparece dentro, y quiero que aparezca como la primera y pongo el mismo código.

Ah, y al ponerlo tiene que aparecer sí o sí el texto desplazado hacia la derecha? Es que me aparece a la misma posición que las viñetas y queiro que aparezca normal.
No se por que haces esto:
   <A href="#Lanzacohetes">
    <li>Lanzacohetes</li></A>

Cuando deberia de ser:
   
    <li><A href="#Lanzacohetes">Lanzacohetes</A></li>

Y todo XHTML debe de ser en minuscula si no puede no funcionar, ose esto:
<A name="Subfusiles"><H1>Subfusiles</H1></A>

Deberia de ser:
<a name="Subfusiles"><h1>Subfusiles</h1></a>

Y si ese es el codigo que estas usando y no solo un ejemplo, digo aunque sea un ejemplo no servira por que no estas cerrando las etiquetas cuando debes, las dejas abiertas y abres mas antes de cerrar.
Omar G.
Bff es que me he armado un lío... xD y sí me funciona, tú que tienes permiso para ver mis foros privados, te dejo el hilo para que lo veas...

http://www.todocod.eshost.es/foro/showth...44#pid1344
Lo puse así para liarme menos pero creo que me lié más, digo con lo del espacio y las mayúsculas pero bueno... Aún así me funciona y no creo que sea por eso, será por que me dejé algún code abierto y entonces se me mete dentro... míralo ahí que sale en el link.

No, no es un ejemplo xD
Colaboradores
Omar G.
This forum uses Lukasz Tkacz MyBB addons.