Importante:

¿Como pedir soporte? (Marzo 18, 2015)

[Actualizando] Error login al actualizar
Hola chicos, antes que nada me gustaría daros las gracias por el soporte que brindáis a los usuarios, es la primera vez que participo en el foro. El...

Hola chicos, antes que nada me gustaría daros las gracias por el soporte que brindáis a los usuarios, es la primera vez que participo en el foro.

El caso es que estoy actualizando my foro de la versión 1.8.3 a la 1.8.5. Ya he descargado los archivos, los he subido a mi FTP y seguido la dirección miforo.com/install y pinchado en la opción de actualizar el foro a la versión 1.8.5. El problema que tengo es que al pedirme el username y el password de administrador me da el mensaje de error The username you have entered appears to be invalid. Estoy totalmente seguro que introduzco los datos correctamente (los tengo apuntados en KeePass para verificarlo, además que ayer mismo entré al panel de administración del foro con estos mismos datos). ¿Puede ser porque mi usuario y password tenga carácteres especiales?

Un saludo, Kaisser.
0 0
Tema anterior Tema siguiente
(July 17, 2015, 11:11 pm)Kaisser escribió:  Hola chicos, antes que nada me gustaría daros las gracias por el soporte que brindáis a los usuarios, es la primera vez que participo en el foro.

El caso es que estoy actualizando my foro de la versión 1.8.3 a la 1.8.5. Ya he descargado los archivos, los he subido a mi FTP y seguido la dirección miforo.com/install y pinchado en la opción de actualizar el foro a la versión 1.8.5. El problema que tengo es que al pedirme el username y el password de administrador me da el mensaje de error The username you have entered appears to be invalid. Estoy totalmente seguro que introduzco los datos correctamente (los tengo apuntados en KeePass para verificarlo, además que ayer mismo entré al panel de administración del foro con estos mismos datos). ¿Puede ser porque mi usuario y password tenga carácteres especiales?

Un saludo, Kaisser.


¿Esto te pasa después de actualizar?
Prueba a actualizar desde http://montepirico.com/foro/install/upgrade.php.
Y quizas lo mas importante antes seria conectar MyBB a la base de datos.

Saludos. Smile
0
Hola BitLiberal, gracias por contestar, paso a comentarte. El problema no me pasa al haber actualizado porque no puedo finalizar el proceso de actualización, actualmente tengo la versión 1.8.3 y quiero actualizar a la 1.8.5, pero no logro finalizar el proceso. Y sí, intentando buscar algún otro nombre de usuario por si el que yo introducía era incorrecto he roto la conexión con la base de datos. ¿Me podrías indicar como arreglarlo por favor?

Gracias, un saludo Kaisser.
0
Creo que en resumen tenes que ver esto, que es lo que te indica @BitLiberal:

Cita:SQL Error:1045 - Access denied for user 'fapkvpik_foro'@'localhost' (using password: YES)Query:[READ] Unable to connect to MySQL server

Cuando creas una BD para tu foro asignas un usuario y su password, claramente ese no es el usuario que estas usando, existen varias alternativas, pero si perdiste los datos, creo que lo mas simple es crear un nuevo usuario en tu "Panel Web" para tu BD, y después configurar ese usuario nuevo en tu archivo config.php de Mybb en la carpeta foro/inc/config.php.

al abrir el archivo veras esto:

Cita:$config['database']['type'] = 'mysqli';
$config['database']['database'] = 'mi_foro';
$config['database']['table_prefix'] = 'mybb_';

$config['database']['hostname'] = 'localhost';
$config['database']['username'] = 'miUserName_foro';
$config['database']['password'] = 'miPassword';

Por otro lado, y creo que seria la primera verificación que tenes que hacer, ¿esta funcionando tu servidor de BD?, cuando entras a tu panel web, cPanel/Plesk/etc... y vas a las opciones de BD, si te conectas el server ¿te funciona?.
0
Muchas gracias por contestar XEDE, de veras. Como ves soy un usuario muy novato y con conocimientos muy limitados, pero de lo que comentabas he sacado la conclusión que al cambiar la contraseña en la base de datos no había actualizado esa contraseña en el archivo config.php, ahora ya lo hice y parece ser que el error en la conexión con la base de datos ya está solucionado.

Por otra parte, el problema inicial existe, es decir, si sigo la dirección http://montepirico.com/foro/install/upgrade.php al introducir el usuario y contraseña para actualizar (que sé 100% seguro que es correcto) me da error y dice que el usuario introducido parece ser inválido. ¿A qué se debe este error? ¿Puede ser porque la contraseña contiene carácteres especiales como el o : o -?

Un saludo, Kaisser.
0
Que bueno que lo solucionaste, sobre el tema de actualización, la verdad no sabría decirte, entiendo que si usas codificación utf-8 no tendría que pasar eso, pero en caso que uses un usuario/password con caracteres raros, podes cambiarlo a uno mas simple para actualizar, y después cambiar la password nuevamente a una complicada, aunque ya sobre ese tema no tengo idea si es que pueda ser un problema de caracteres.
0
Muchas gracias tanto a BitLiberal como XEDE, finalmente he podido actualizar el foro a la versión 1.8.5. Tal y como comentaba XEDE, he probado cambiando el nombre de usuario administrador desde PHPmyadmin (que también contenía carácteres especiales) y entonces si he podido actualizar.

Un saludo, Kaisser.
0
Tema cerrado

Colaboradores: XEDE , Kaisser , BitLiberal

This forum uses Lukasz Tkacz MyBB addons.