Importante:

¿Como pedir soporte? (Marzo 18, 2015)

[Ayuda] QuickReply!
Bueno, tengo 2 pequeñas dudas que me inquietan, La primera es que yo como administrador (solamente con la cuenta administrador pasa) cuando entro en...

Bueno, tengo 2 pequeñas dudas que me inquietan,

 La primera es que yo como administrador (solamente con la cuenta administrador pasa) cuando entro en un tema me dirige directamente hacia abajo del todo en el quickreply y esto no pasaba antes. me dirige con o sin el pid del post:
[Imagen: JgOJURC.png]


Y la segunda duda, ¿Como hago o que tengo que hacer para que el editor avanzado se active solo cuando damos click en el apartado de quickreply?


Gracias
0 0
Tema anterior Tema siguiente
(July 14, 2015, 6:21 am)comy91 escribió:  Bueno, tengo 2 pequeñas dudas que me inquietan,

 La primera es que yo como administrador (solamente con la cuenta administrador pasa) cuando entro en un tema me dirige directamente hacia abajo del todo en el quickreply y esto no pasaba antes. me dirige con o sin el pid del post:


Y la segunda duda, ¿Como hago o que tengo que hacer para que el editor avanzado se active solo cuando damos click en el apartado de quickreply?


Gracias

Suponiendo que te refieres a que automaticamente te hace scroll hacia el quickreply:
  • ¿Has instalado algun plugin recientemente que tenga que ver con la respuesta rapida?
  • ¿Has añadido un autofocus al textarea de la respuesta rapida?
Si puedes, dejar aqui la plantilla del quickreply.

Saludos. Smile
0
Creo yo, que utilizamos plugins diferentes, intenta con otro
0
(July 14, 2015, 3:22 pm)BitLiberal escribió:  Suponiendo que te refieres a que automaticamente te hace scroll hacia el quickreply:
  • ¿Has instalado algun plugin recientemente que tenga que ver con la respuesta rapida?
  • ¿Has añadido un autofocus al textarea de la respuesta rapida?
Si puedes, dejar aqui la plantilla del quickreply.

Saludos. Smile

No, el ultimo plugin que instale fue el de MySupport.

No he añadido autofocus a la textarea


aqui te dejo la plantilla quickreply:
<div id="quickreply_spinner" class="showthread_spinner" style="display: none"><img src="{$theme['imgdir']}/spinner.gif" /></div>
<br />
{$moderation_notice}
<form method="post" action="newreply.php?tid={$tid}&amp;processed=1" name="quick_reply_form" id="quick_reply_form">
	<input type="hidden" name="my_post_key" value="{$mybb->post_code}" />
	<input type="hidden" name="subject" value="RE: {$reply_subject}" />
	<input type="hidden" name="action" value="do_newreply" />
	<input type="hidden" name="posthash" value="{$posthash}" id="posthash" />
	<input type="hidden" name="quoted_ids" value="" id="quoted_ids" />
	<input type="hidden" name="lastpid" id="lastpid" value="{$last_pid}" />
	<input type="hidden" name="from_page" value="{$page}" />
	<input type="hidden" name="tid" value="{$tid}" />
	<input type="hidden" name="method" value="quickreply" />

	<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
		<thead>
			<tr>
				<td class="thead" colspan="2">
					<div class="expcolimage"><img src="{$theme['imgdir']}/collapse{$collapsedimg['quickreply']}.png" id="quickreply_img" class="expander" alt="[-]" title="[-]" /></div>
					<div><strong>{$lang->quick_reply}</strong></div>
				</td>
			</tr>
		</thead>
		<tbody style="{$collapsed['quickreply_e']}" id="quickreply_e">
			<tr>
              <td class="{$trow}" valign="top" width="4%">
				
				</td>
				<td class="{$trow}">
					<div style="width: 95%">
                      <div class="editor_control_bar" style="width: 100%; padding: 4px; margin-top: 3px; display: none;" id="quickreply_multiquote">
						<span class="smalltext">
							{$lang->quickreply_multiquote_selected} <a href="./newreply.php?tid={$tid}&amp;load_all_quotes=1" onclick="return Thread.loadMultiQuoted();">{$lang->quickreply_multiquote_now}</a> {$lang->or} <a href="javascript:Thread.clearMultiQuoted();">{$lang->quickreply_multiquote_deselect}</a>.
                        
						</span>
					</div>
                      
						<textarea style="width: 100%; padding: 4px; margin: 0;" rows="8" cols="80" name="message" id="message" tabindex="1"></textarea>{$codebutquick}
					</div> <br />
                  
              <div class="float_left"> {$option_signature} <label><input type="checkbox" class="checkbox" name="postoptions[disablesmilies]" value="1" />&nbsp;{$lang->disable_smilies}</label>{$closeoption} </div>
                  
                  <div class="float_right" style="margin-top: -10px; margin-right: 4%;"><input type="submit" class="button" value="Submit reply" tabindex="2" accesskey="s" id="quick_reply_submit" /> <input type="submit" class="button" name="previewpost" value="{$lang->preview_post}" tabindex="3" /></div>
                  
					
				</td>
			</tr>
			{$captcha}
			
		</tbody>
	</table>
</form>
0
(July 14, 2015, 8:48 pm)Cluster escribió:  Creo yo, que utilizamos plugins diferentes, intenta con otro


El plugin que utilizo es este: http://community.mybb.com/thread-155797.html
0
Y una cuestión interesante es que el scrool automático hacia el quickreply me pasa solo con la cuenta de admin, he intentado con cuentas normales o sin conectarme y no hace el scroll automático
0
(July 14, 2015, 11:10 pm)comy91 escribió:  Y una cuestión interesante es que el scrool automático hacia el quickreply me pasa solo con la cuenta de admin, he intentado con cuentas normales o sin conectarme y no hace el scroll automático

¿Puedes dejarme por privado una cuenta de admin y lo compruebo?

Saludos. Smile
0
Comprobado con Google Chrome y Mozilla Firefox, y no pasa nada, no hay scroll.
Cambia de navegador o borra cache, a ver si se soluciona. 

Saludos. :)
0
(July 15, 2015, 3:08 am)BitLiberal escribió:  Comprobado con Google Chrome y Mozilla Firefox, y no pasa nada, no hay scroll.
Cambia de navegador o borra cache, a ver si se soluciona. 

Saludos. Smile

Nada, he intentado todo! Sad
0
Al parecer tienes instalado el plugin Quick Advanced Editor.

Prueba esto:

Vete a ACP > Estilos y Plantillas > Plantillas > Plantillas globales > codebutquick
Busca esta linea:
rtl: {$lang->settings['rtl']},

Cambiala por esto:
rtl: {$lang->settings['rtl']},
autofocus: false,

Saludos. Smile
Última modificación: July 15, 2015, 6:54 am por BitLiberal.
0

Colaboradores: XEDE , comy91 , Cluster , BitLiberal

This forum uses Lukasz Tkacz MyBB addons.