Problemas despues de formatear mi servidor.
* URL del foro: www.redminecraft.es/foro * Versión del foro: 1.6.8 * Actualización: Instalacion "limpia". Tengo alojado mi foro en un servidor cas...


Tengo alojado mi foro en un servidor casero, con linux y apache.

Configure todo el foro y sus plugins y todo funcionaba perfecto. El caso es que tuve que formatear por que algo no iba bien en linux (nada que ver con el foro), el caso es que hice backup del directorio del foro, asi como de la base de datos.

Una vez formateado y reinstalado linux, instale apache y demas para otra vez dar servicio web. Copie otra vez la carpeta del foro igual que estaba antes, e importe la base de datos.

Todo perfecto a falta de dos detalles.

El foro esta en la carpeta www/foro con lo que hago un redireccionamiento con un .htaccess con este contenido:


Cita:redirect 301 / http://www.redminecraft.es/foro/index.php


Pero no funciona, cuando alguien entra en www.redminecraft.es en vez de ir a www.redminecraft.es/foro/index.php sale una lista de directorios (entre los que se encuentra /foro).

Asi que me toca hacer un archivo index.php en la raiz de www/ con este contenido:


Cita:<? header("HTTP/1.1 301 Moved Permanently", TRUE, 301);
@header("Location: http://www.redminecraft.es/foro"); ?>


Con este index.php si que redirecciona, al escribir www.redminecraft.es te lleva a www.redminecraft.es/foro pero por que con el .htaccess no?.

Luego, otra cosa que me trae loco es el google SEO. Supuestamente no he modificado nada, es decir, he copiado la carpeta del foro y la base de datos, he formateado y reinstalado, para dejarlo todo otra vez en el mismo sitio todo, entonces, por que por ejemplo ya no funciona Google SEO URL?, cuando esta activado, entro en una seccion del foro, me aparece una pagina en blanco con este texto:


Cita:Not Found

The requested URL /foro/Forum-Moderación was not found on this server.
Apache/2.2.22 (Ubuntu) Server at www.redminecraft.es Port 80


Lo primero que me llama la atencion es que lo que lleva acento sale con caracteres raros, pero si voy a una seccion que no tenga acentos en su descripcion pasa lo mismo:


Cita:Not Found

The requested URL /foro/Forum-Papelera-de-reciclaje was not found on this server.
Apache/2.2.22 (Ubuntu) Server at www.redminecraft.es Port 80


Tengo el siguiente .htaccess en la raiz de la instalacion de mi foro:


Cita:# EXAMPLE .htaccess FOR MYBB WITH GOOGLE SEO URL
# -------------------------------------------------------------------
# This file is identical to MyBB's htaccess.txt example file,
# with rewrite rules for a standard Google SEO install added.
#
# Before using this file please make sure to:
#
# - replace /MyBB/ with your forum folder, e.g. / or /forum/
# - replace yoursite/MyBB with your forum URL
# - name the file '.htaccess' (starting with the dot, no .txt)
#
# Alternatively you can add the required rewrite rules to your
# existing .htaccess, the specific rules required will be displayed
# on the plugin status page once Google SEO URL is enabled.
# -------------------------------------------------------------------

Options -MultiViews +FollowSymlinks -Indexes

#
# If mod_security is enabled, attempt to disable it.
# - Note, this will work on the majority of hosts but on
# MediaTemple, it is known to cause random Internal Server
# errors. For MediaTemple, please remove the block below
#
<IfModule mod_security.c>
# Turn off mod_security filtering.
SecFilterEngine Off

# The below probably isn't needed, but better safe than sorry.
SecFilterScanPOST Off
</IfModule>

#
# MyBB "search engine friendly" URL rewrites
# - Note, for these to work with MyBB please make sure you have
# the setting enabled in the Admin CP and you have this file
# named .htaccess
#
<IfModule mod_rewrite.c>
RewriteEngine on

# Some hosts need a RewriteBase specification.
RewriteBase /foro/

# Google SEO workaround for search.php highlights:
# Make this rule the first rewrite rule in your .htaccess!
RewriteRule ^([^&]*)&(.*)$ http://www.redminecraft.es/foro/$1?$2 [L,QSA,R=301]

# Google SEO 404:
ErrorDocument 404 /foro/misc.php?google_seo_error=404

# Google SEO Sitemap:
RewriteRule ^sitemap\-([^./]+)\.xml$ misc.php?google_seo_sitemap=$1 [L,QSA,NC]

# Google SEO URL Forums:
RewriteRule ^Forum\-([^./]+)$ forumdisplay.php?google_seo_forum=$1 [L,QSA,NC]

# Google SEO URL Threads:
RewriteRule ^Thread\-([^./]+)$ showthread.php?google_seo_thread=$1 [L,QSA,NC]

# Google SEO URL Announcements:
RewriteRule ^Announcement\-([^./]+)$ announcements.php?google_seo_announcement=$1 [L,QSA,NC]

# Google SEO URL Users:
RewriteRule ^User\-([^./]+)$ member.php?action=profile&google_seo_user=$1 [L,QSA,NC]

# Google SEO URL Calendars:
RewriteRule ^Calendar\-([^./]+)$ calendar.php?google_seo_calendar=$1 [L,QSA,NC]

# Google SEO URL Events:
RewriteRule ^Event\-([^./]+)$ calendar.php?action=event&google_seo_event=$1 [L,QSA,NC]

# Default MyBB Rewrite Rules:
RewriteRule ^forum-([0-9]+)\.html$ forumdisplay.php?fid=$1 [L,QSA]
RewriteRule ^forum-([0-9]+)-page-([0-9]+)\.html$ forumdisplay.php?fid=$1&page=$2 [L,QSA]

RewriteRule ^thread-([0-9]+)\.html$ showthread.php?tid=$1 [L,QSA]
RewriteRule ^thread-([0-9]+)-page-([0-9]+)\.html$ showthread.php?tid=$1&page=$2 [L,QSA]
RewriteRule ^thread-([0-9]+)-lastpost\.html$ showthread.php?tid=$1&action=lastpost [L,QSA]
RewriteRule ^thread-([0-9]+)-nextnewest\.html$ showthread.php?tid=$1&action=nextnewest [L,QSA]
RewriteRule ^thread-([0-9]+)-nextoldest\.html$ showthread.php?tid=$1&action=nextoldest [L,QSA]
RewriteRule ^thread-([0-9]+)-newpost\.html$ showthread.php?tid=$1&action=newpost [L,QSA]
RewriteRule ^thread-([0-9]+)-post-([0-9]+)\.html$ showthread.php?tid=$1&pid=$2 [L,QSA]

RewriteRule ^post-([0-9]+)\.html$ showthread.php?pid=$1 [L,QSA]

RewriteRule ^announcement-([0-9]+)\.html$ announcements.php?aid=$1 [L,QSA]

RewriteRule ^user-([0-9]+)\.html$ member.php?action=profile&uid=$1 [L,QSA]

RewriteRule ^calendar-([0-9]+)\.html$ calendar.php?calendar=$1 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)\.html$ calendar.php?action=yearview&calendar=$1&year=$2 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)\.html$ calendar.php?calendar=$1&year=$2&month=$3 [L,QSA]
RewriteRule ^calendar-([0-9]+)-year-([0-9]+)-month-([0-9]+)-day-([0-9]+)\.html$ calendar.php?action=dayview&calendar=$1&year=$2&month=$3&day=$4 [L,QSA]
RewriteRule ^calendar-([0-9]+)-week-(n?[0-9]+)\.html$ calendar.php?action=weekview&calendar=$1&week=$2 [L,QSA]

RewriteRule ^event-([0-9]+)\.html$ calendar.php?action=event&eid=$1 [L,QSA]

<IfModule mod_env.c>
SetEnv SEO_SUPPORT 1
</IfModule>
</IfModule>

#
# If Apache is compiled with built in mod_deflade/GZIP support
# then GZIP Javascript, CSS, HTML and XML so they're sent to
# the client faster.
#
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/x-javascript text/css text/html text/xml
</IfModule>


Y ya por ultimo, no se con seguridad si antes existia, pero al instalar Google SEO, no te deberia crear un sitemap del sitio?, teoricamente al ir a www.redminecraft.es/foro/sitemap-index.php deberia salir el sitemap, pero me dice que no existe ese archivo.

Por lo demas todo funciona perfectamente.

Como podria solucionar estos problemas?.

Gracias y un saludo.
si no tienes web principal no veo la necesidad de meter tu web en /foro/ y el sitemap es xml no php
:)
Ahora mismo no hay web principal, pero la habra en breve, por eso he metido el foro en esa carpeta.

El sitemap .... fallo mio al explicarlo, queria decir .xml y puse .php por error. Pero vamos, igualmente, pongo www.redminecraft.es/foro/sitemap-index.xml y me dice lo mismo, que no encuentra nada.

Un saludo.
si no me equivoco debes ponerla en la carpete robot.txt ahi pones http://www.redminecraft.es/foro/sitemap-index.xml esta carpeta debe de estar en la raiz de tu foro....
creo que lo que tienes es un problema del mod rewrite
:)
Efectivamente, el problema estaba en el mod_rewrite, Sleepy

Ahora solo me faltaria ver por que no va el redireccionamiento con .htaccess

Sigue sin redireccionarme a la carpeta "/foro" cuando voy a www.redminecraft.es a traves de .htaccess, tengo que hacerlo mediante un index.php

Un saludo.
haz una redireccion 301 en el .htaccess de esta forma
redirect 301 / http://www.redminecraft.es/foro/index.php 
Última modificación: 26 Aug, 2012, 5:49 am por Z-Blue.
Colaboradores
sobasleo papi Cluster
This forum uses Lukasz Tkacz MyBB addons.