Importante:

¿Como pedir soporte? (Marzo 18, 2015)

Pegar imagenes de {$} en postbit
* URL del foro: http://www.portalbreak.com/ * Versión del foro: 1.6 * Actualización: Ninguna Buenas a todos. Tengo una pregunta medio problematic...


Buenas a todos.
Tengo una pregunta medio problematica.
Estoy editando mi postbit. y pues como ustedes sabran:

Si pongo este codigo en el postbit
<img src="http://www.jorge-fernandez.es/cosme/departamento/verde16.png"><img src="http://www.jorge-fernandez.es/cosme/departamento/rojo16.png">
Aparece así:
[Imagen: verde16.png][Imagen: rojo16.png]
Notan que las imagenes aparecen una pegada a la otra. Y así aparece en mi postbit. Ya vacán.



Pero si yo pongo esto (Nótese que los codigos están pegados)
Aclaración: El icono de online en mi caso es este: [Imagen: buddy_online.gif] Y no tiene espacio a los costados, es de 7 x 35 y esta pintado todo.
{$post['onlinestatus']}<img src="http://www.jorge-fernandez.es/cosme/departamento/verde16.png">
Aparece así
[Imagen: buddy_online.gif] [Imagen: verde16.png]
Hay un espacio entre las dos imagenes


O si pongo esto: (Los codigos están pegados, no hay espacio entre los codigos img y ($post..
<img src="http://www.jorge-fernandez.es/cosme/departamento/rojo16.png">{$post['groupimage']}
Aparece así:
[Imagen: rojo16.png] [Imagen: administrador.png]
Hay espacio entre las dos imagenes

A las finales si agrego esto: Los dos codigos están pegados.
{$post['onlinestatus']}{$post['groupimage']}
Aparece así:
[Imagen: buddy_online.gif] [Imagen: administrador.png]

Y no quiero que aparezcan separados. Pues he revisado el postbit_online. postbit_offline y postbit_groupimage y en ninguna de ellas aparece &nbsp; (Código para hacer un espacio). Aparecen solo los codigos de <a href=.. e <img>
Y no entiendo de donde aparece ese espacio entre las dos imagenes de grupo de imagenes y estado.

He revisado también el showthread.php y no hay &nbsp; para decir que ese es el problema.
Tema anterior Tema siguiente
Ponlo asi a ver que tal resulta
<img src="http://www.jorge-fernandez.es/cosme/departamento/verde16.png"><br><br><img src="http://www.jorge-fernandez.es/cosme/departamento/rojo16.png">
No, yo no quiero que vaya abajo ni separado. Yo quiero evitar eso y mas bien quiero que vayan esas dos imagenes pegadas. Que no haya espacio entre ellas.

Así
[Imagen: buddy_online.gif][Imagen: administrador.png]
umm pegaaqui el postbit a ver el codigo. ya uqe me parece raro que no haya ningun espaco por ahi Wink
{$ignore_bit}
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder" style="{$post_extra_style} {$post_visibility}" id="post_{$post['pid']}">
<tr bgcolor="#f1f3f5">
<td  colspan="2">

<table border="0" class="cabt" width="100%">
<tr><td>
<img src="images/post_old.png"> {$post['postdate']}, {$post['posttime']} 
<span class="textcabt">{$post['posturl']}</span></td></tr>
</table>

</td>
</tr> 
<tr>
		<td class="{$altbg}" width="23%" valign="top" style="white-space: nowrap; text-align: center;" > <a name="pid{$post['pid']}" id="pid{$post['pid']}"></a>
             
		<strong><span class="largetext">{$post['profilelink']}</span></strong> <br />              
<table class="postrow" border="0" width="100%"><tr><td>
<span class="smalltext">
			{$post['usertitle']}<br />
			{$post['useravatar']}<br />
			{$post['onlinestatus']}{$post['groupimage']}
                        {$post['user_details']}
		</span>
</tr></td></table>


	</td>
      

	<td class="pmessage" valign="top">
		<table width="100%">

			<tr >
<td>   <span class="tittletext"><strong>
{$post['icon']}{$post['subject']} {$post['subject_extra']}</strong></span>

			<br />
			<div id="pid_{$post['pid']}" class="post_body">
				{$post['message']}
			</div>
			{$post['attachments']}
			{$post['signature']}
			<div style="text-align: right; vertical-align: bottom;" id="post_meta_{$post['pid']}">
				<div id="edited_by_{$post['pid']}">{$post['editedmsg']}</div>
				{$post['iplogged']}
			</div>
		</td></tr>
	</table>
</td>
</tr>
<tr>
	<td class="{$altbg}" style="white-space: nowrap; text-align: center; vertical-align: middle;"><span class="smalltext">{$post['button_email']}{$post['button_pm']}{$post['button_www']}{$post['button_find']}{$post['button_rep']}</span></td>
	<td class="{$altbg}" style="vertical-align: middle;">
		<table width="100%" border="0" cellpadding="0" cellspacing="0">
			<tr valign="bottom">
				<td align="left" ><span class="smalltext"></span>{$post['thanks']}</td>
				<td align="right">{$post['button_edit']} {$post['button_reply_pm']}{$post['button_replyall_pm']}<span class="separar"></span>{$post['button_quote']}{$post['button_forward_pm']}<span class="separar"></span>{$post['button_multiquote']}{$post['button_delete_pm']}</td>
			</tr>
		</table>
	</td>
</tr>{$post['thxdsp_inline']}</tbody>
</table>{$post['thxdsp_outline']}
</br>
ya revisaste su class?
No tiene class esos dos codigos. solo tienen etiquetas <img y <a href y ninguna contiene class.
fijate en esta parte
Cita:<span class="smalltext">
            {$post['usertitle']}<br />
            {$post['useravatar']}<br />
            {$post['onlinestatus']}{$post['groupimage']}
                        {$post['user_details']}
        </span>
si te das cuenta esa clase llamada smalltext marca las propiedades de usertitle, useravatar y onlinestatus ademas de que tienes sendos <br>
Lamentablemente probé quitandolo y  no sucede nada. Aparte ese class no afecta en anda ya que yo puse esto para probar si las imagenes quedaban unidas.

Todos los codigos están juntos.
Cita:<img src="http://www.jorge-fernandez.es/cosme/departamento/verde16.png"><img src="http://www.jorge-fernandez.es/cosme/departamento/rojo16.png">{$post['onlinestatus']}{$post['groupimage']}

Y quedó así:
[Imagen: verde16.png][Imagen: rojo16.png] [Imagen: buddy_online.gif] [Imagen: administrador.png]
Nótese que las dos imagenes de códigos <img> estan pegadas y las de {$} se separan.

Y con esto llegamos a la conclusión que ese <span> no afecta si las imagenes están pegadas o no.

Está que me quiere dar jaqueca
Revisando el codigo donde aparecen los dos rangos de tu perfil, me encuentro con esto
<!-- start: postbit_groupimage -->
<img alt="Administrador" src="images/rangos/administrador.png  "/>
<!-- end: postbit_groupimage --><img alt="Moderador" src="images/rangos/moderador.png  "/><br/><br/>
                        <img src="rank/20.gif"/> <font color="Plugins - Oculta IMG a invitadose73b0">Cetro de Rubí</font> <br/>
En medio de los dos rangos aparecen los <br> que provocan esa separacion y por lo visto los tienes en postbit_groupimage

Colaboradores: Xpress , pes style , papi , DARKNESSDH

This forum uses Lukasz Tkacz MyBB addons.