lightbox... en algunos foros ?
Hola e puesto un sistema de lightbox a las imagenes [img] medianta mycode, asi las ajusto de tamaño y cuando las quieran ver grandes les hacen click ...

Hola e puesto un sistema de lightbox a las imagenes [img] medianta mycode, asi las ajusto de tamaño y cuando las quieran ver grandes les hacen click y les sale la imagen en el lightbox pero el problema es que no sale el lightbox en todos los foros... solo en un par

este es el mycode

<a href="$1" rel="lightbox"><img style="max-width:500px;" src="$1" alt="İmage"/></a>

y este el codigo que va en la plantilla... lo probe en headerinclude y showthread y nada solo en un par de foros se abria lightbox en las otras solo me abria la url de la foto

<link href="css/lightbox.css" rel="stylesheet" />
<script src="jscripts/jquery-1.7.2.min.js"></script>
<script src="jscripts/lightbox.js"></script>

uso este lightbox = http://lokeshdhakar.com/projects/lightbox2/
Última modificación: 20 Aug, 2012, 8:23 am por xxyogaxx.
Debes buscar la diferencia entre una pagina y la otra, revisa el codigo fuente.
Omar G.
gracias creo que encontre el problema...

el codigo de una imgen que no se ve el lightbox tiene rel="nofollow"


Cita:<a rel="nofollow" href="http://i.imgur.com/YSr6g.png" rel="lightbox"><img style="max-width:500px;" src="http://i.imgur.com/YSr6g.png" alt="İmage"/></a>


la imagen que si muestra bien el lightbox

Cita:<a href="http://www.pisitoenmadrid.com/fotolog/images/20080120211958_bender.jpg" rel="lightbox"><img style="max-width:500px;" src="http://www.pisitoenmadrid.com/fotolog/images/20080120211958_bender.jpg" alt="İmage"/></a>


no tiene el rel="nofollow"...
pienso que ese puede ser el problema, es lo unico distinto que veo entro los dos, pero al parecer se introduce de forma automatica en el html de las imagenes... como lo puedo eliminar ?
La unica razon por la que veo que podria pasar, es por que el mensaje fue creado por un usuario cuyo grupo tiene la opcion de nofollow en sus firmas activado.

Algun plugin que podria estar causando esto en tu lista?
Omar G.
mm no creo que sea por el usuario, despues de todo yo cree los 2 mensajes...
plugins, tengo estos activos

*Ads after first post
*Avatars in Thread Listing
*MyBB GoMobile
*GoogleSeo
*Only Show Links to Repliers
*Template Conditionals
La unica que puede ser es lo que te mencione (revisando el class_parser.php es la unica forma en que se agrega un nofollow a los enlaces).

Otro podria ser el Google SEO, intenta desactivar la opcion de nofollow que tiene.
Omar G.
ok gracias ya vi esa opcion solo me surgio otro problema directo con mybb~
¿Entonces si era eso (Google SEO)?
Omar G.
luego te informo no puedo probarlo aun... las plantillas se me borran! abrire un nuevo tema =/
Colaboradores
Omar G.
This forum uses Lukasz Tkacz MyBB addons.