Google SEO
url : www.designwarez.com.ar version 1.4.9 problema.: bueno, lo que queria saber es cuando los instalaba..segun el tutorial que questa aqui, cuando...

url : www.designwarez.com.ar

version 1.4.9


problema.: bueno, lo que queria saber es cuando los instalaba..segun el tutorial que questa aqui, cuando modifico el archivo functions.php como lo hago?, por que a esta altura con las cosas que tengo modificadas si o si tendriaa q cambiarlo pero no se como teniendo en cuenta el otro archivo que habria que asignarle el nombre de este ultimo ^^
bajate la ultima vercion del plugin,
lo de la functions.php, pues si no le has agregado nada tu, en la carpeta del plugin viene un archivo listo para las verciones de mybb si usas la 1.4.10, busca el archivo functions.php.14.10 renombralo a functions.php y subelo a inc reemplazando al original.
lo de las modificaciones al .htaccess dependen de la ubicacion de tu foro, y del hosting, bueno sigue la guia si te falta algo consulta.
Saludos
bueno subi el function.php.14.9 creo q se llamaba (uso mybb 1.4.9 xp), y ahora iba a hacer eso del htaccess, pero cuando hago:

7- Abrimos htaccess.txt hay que modificar algo a si que les pondre que hay que modificar:

Buscar
Código PHP:
    RewriteBase /mybb/



No encuentro esa linea e_E

adjunto el archivo para q vean que no estoy loco(?




EDITED: ahora que me fijo, reemplaze el archivo function y me tira error en una funcion hidetag(), hay alguna manera de fusionar los dos archivo copiando y pegando o algo asi(? xp
agregala arriba de esta linea
RewriteRule ^([^&]*)&(.*)$ http://yourhost/MyBB/$1?$2 [L,QSA,R=301]
osea asi
RewriteBase /foro/
RewriteRule ^([^&]*)&(.*)$ http://www.designwarez.com.ar/foro/$1?$2 [L,QSA,R=301]
a ver...yo hasta ahora modifique mi functions.php solamente agregando la funcion creo q hidetags() que era loq  me daba error y faltaba, despues modifique el .htaccess como me dijiste ...pero me tira error 404 T_T . ahi lo adjunto al que agregue, y al que tenia por las dudas(?
up                   =3
si no te funka es problema del webhosting, si es pago, pedile al de soporte que te habilite el modulo rewrite para IIS Wink y te va a andar joya.
puede ser que sea eso black gracias =B, ya pedi soporte a ver que onda...si hay posibilidad de que sea otra cosa avisen jeje
ahora despues de actualizar a 1.4.11 baje la nueva version del google seo y subi todo, pero me tira un error con el functions.php que subo

--- functions.php 2009-11-29 16:04:36.000000000 +0100 +++ functions.php 2009-12-02 17:39:41.813958311 +0100 @@ -830,6 +830,16 @@ */ function multipage($count, $perpage, $page, $url) { + if(function_exists("google_seo_url_multipage")) + { + $newurl = google_seo_url_multipage($url); + + if($newurl) + { + $url = $newurl; + } + } + global $theme, $templates, $lang, $mybb; if($count <= $perpage) @@ -4196,6 +4206,16 @@ */ function get_profile_link($uid=0) { + if(function_exists("google_seo_url_profile")) + { + $link = google_seo_url_profile($uid); + + if($link) + { + return $link; + } + } + $link = str_replace("{uid}", $uid, PROFILE_URL); return htmlspecialchars_uni($link); } @@ -4208,6 +4228,16 @@ */ function get_announcement_link($aid=0) { + if(function_exists("google_seo_url_announcement")) + { + $link = google_seo_url_announcement($aid); + + if($link) + { + return $link; + } + } + $link = str_replace("{aid}", $aid, ANNOUNCEMENT_URL); return htmlspecialchars_uni($link); } @@ -4273,6 +4303,16 @@ */ function get_forum_link($fid, $page=0) { + if(function_exists("google_seo_url_forum")) + { + $link = google_seo_url_forum($fid, $page); + + if($link) + { + return $link; + } + } + if($page > 0) { $link = str_replace("{fid}", $fid, FORUM_URL_PAGED); @@ -4296,6 +4336,16 @@ */ function get_thread_link($tid, $page=0, $action='') { + if(function_exists("google_seo_url_thread")) + { + $link = google_seo_url_thread($tid, $page, $action); + + if($link) + { + return $link; + } + } + if($page > 1) { if($action) @@ -4335,6 +4385,16 @@ */ function get_post_link($pid, $tid=0) { + if(function_exists("google_seo_url_post")) + { + $link = google_seo_url_post($pid, $tid); + + if($link) + { + return $link; + } + } + if($tid > 0) { $link = str_replace("{tid}", $tid, THREAD_URL_POST); @@ -4356,6 +4416,16 @@ */ function get_event_link($eid) { + if(function_exists("google_seo_url_event")) + { + $link = google_seo_url_event($eid); + + if($link) + { + return $link; + } + } + $link = str_replace("{eid}", $eid, EVENT_URL); return htmlspecialchars_uni($link); } @@ -4371,6 +4441,16 @@ */ function get_calendar_link($calendar, $year=0, $month=0, $day=0) { + if(function_exists("google_seo_url_calendar")) + { + $link = google_seo_url_calendar($calendar, $year, $month, $day); + + if($link) + { + return $link; + } + } + if($day > 0) { $link = str_replace("{month}", $month, CALENDAR_URL_DAY); @@ -4409,6 +4489,16 @@ */ function get_calendar_week_link($calendar, $week) { + if(function_exists("google_seo_url_calendar_week")) + { + $link = google_seo_url_calendar_week($calendar, $week); + + if($link) + { + return $link; + } + } + if($week < 0) { $week = str_replace('-', "n", $week);


alguien tiene idea? jeje
eee hago triple post y me soba(? pude instalarlo ejejee era une stupidez ponia el htaccess en la raiz asi del dominio en vez de ponerlo en la carpeta donde tengo el foro xD . mil gracias por la ayuda prestada =B
Última modificación: 31 Dec, 2009, 6:06 pm por powerxd.
Colaboradores
Himura BlackFox
This forum uses Lukasz Tkacz MyBB addons.