[General]  Dos cosas.
Url del foro: LocalHost (Lo estoy construyendo) Versión: 1.6.4 Actualización: 1.6.4 Tema instalado: Nesil basado en TheCure Bueno les cuentro alg...

Url del foro: LocalHost (Lo estoy construyendo)
Versión: 1.6.4
Actualización: 1.6.4
Tema instalado: Nesil basado en TheCure

Bueno les cuentro algo que quiero arreglar, simplemente en la barra donde tengo los links del Portal, Foro etc etc, al clickear el fondo del mismo se vuelve blanco, deberia pasar eso pero no u.u

El theme es muy parecido a este, vos clickeas en "Busqueda" por ejemplo y el mismo se vuelve de un tono blanco, bueno a mi no me pasa. Solo el "FORO" Tiene tono blanco, si clickeo portal por ejemplo sigue "FORO" Blanco, no se si me explique bien.

Plantilla Header:
<a name="top" id="top"></a>	
<div id="golge">
	<div id="container">
		<div id="header">                        
			<div class="logo">
				<a href="{$mybb->settings['bburl']}/index.php">{$mybb->settings['bbname']}</a>
			</div>
			<div id="menu">
				<ul>
					<li class="active"><a href="{$mybb->settings['bburl']}/portal.php">Portal</a></li>
					<li><a href="{$mybb->settings['bburl']}/index.php">Foro</a></li>
					<li><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a></li>
					<li><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a></li>
					<li><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a></li>
					<li><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a></li>
				</ul>
			</div>
			{$welcomeblock}
		</div>
		<div id="content">
			{$pm_notice}
			{$bannedwarning}
			{$bbclosedwarning}
			{$unreadreports}<!-- ProfileComments -->
			{$commentalert}<!-- /ProfileComments -->
			{$pending_joinrequests}
			<navigation>
			<br />

-----------------------------
Y otra cosa en cual me parecio raro. Es lo mostrado en la imagen:





[Imagen: P9lCd.png]




Saludos.-
Para el primer problema, instala el Template Conditionals de MyBBHacks.

Luego reemplza esto:
            <div id="menu">
                <ul>
                    <li class="active"><a href="{$mybb->settings['bburl']}/portal.php">Portal</a></li>
                    <li><a href="{$mybb->settings['bburl']}/index.php">Foro</a></li>
                    <li><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a></li>
                    <li><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a></li>
                </ul>
            </div>

Por esto:
            <div id="menu">
                <ul>
                    <li<if (THIS_SCRIPT == 'portal.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/portal.php">Portal</a></li>
                    <li<if (THIS_SCRIPT == 'index.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/index.php">Foro</a></li>
                    <li<if (THIS_SCRIPT == 'search.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/search.php">{$lang->toplinks_search}</a></li>
                    <li<if (THIS_SCRIPT == 'memberlist.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/memberlist.php">{$lang->toplinks_memberlist}</a></li>
                    <li<if (THIS_SCRIPT == 'calendar.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/calendar.php">{$lang->toplinks_calendar}</a></li>
                    <li<if (THIS_SCRIPT == 'misc.php') then> class="active"</if>><a href="{$mybb->settings['bburl']}/misc.php?action=help">{$lang->toplinks_help}</a></li>
                </ul>
            </div>

Para el seundo problema, MyBB-es lo tenia cuando salio MyBB 1.6.4, quizas Solstice te pueda decir como lo solucionaron.
Omar G.
Lo primero lo logre hacer Big Grin  lo 2do no u.u  me gustaria si cluster me diga como xD
lo segundo no entiendo que hubieras haber podido mover porque en el theme nesil eso esta por defaul alineado a la izquierda
:)
Cluster21 Oct, 2011, 5:24 pmCluster escribió: lo segundo no entiendo que hubieras haber podido mover porque en el theme nesil eso esta por defaul alineado a la izquierda

Que extraño, por ejemplo instalo denuevo el theme sin editar y pasa lo mismo. Probe en el lang si hay algun espacio o algo y no u.u
Cuando MyBB-es actualizo a Mybb 1.6.4 tenia el mismo problema, debe ser algo relacionado con que colocaron un link al perfil alli.
Omar G.
Yo tengo mas de una semana intentando arreglar el segundo problema y no encuentro la solucion, estoy editando un theme para un proyecto y la verdad que no se como arreglar eso...

Ya intente por todos lados xD
Una solución parcial mientras encuentran la solución podría ser algo así:

header_welcomeblock_member

global.css:
.upper_panel span strong a {
margin-left:-5px;
margin-right:-5px;
}

Basándome en el tema de mybb-es.
Omar G.
Colaboradores
Omar G. Gustavo R. Cluster
This forum uses Lukasz Tkacz MyBB addons.