Dar estilo a la firma
Antes de que LEAN esto quiero que sepan que es un Tutorial bastante sencillo y no es gran cosa pero les puede llegar a servir para darle mas estilo a...

Antes de que LEAN esto quiero que sepan que es un Tutorial bastante sencillo y no es gran cosa pero les puede llegar a servir para darle mas estilo a sus foros.

Bueno ahora si empecemos con este tutorial conseguiremos darle un poco de estilo a las firmas de los usuarios de tal manera que nos quede así:


Nos dirigimos a ACP -> Plantillas -> Tu Theme -> Caja del mensaje -> postbit_signature

Sustituimos toda la plantilla por lo siguiente:

<br />
<fieldset style="background: url(images/tutheme/background.png) repeat;
                          border: 2px solid #000;
                         -moz-border-radius:5px;
                         -webkit-border-radius:5px;">

<legend style="background: url(images/tutheme/background.png) repeat;
                          border: 1px solid #000;
                          padding:4px;
                         -moz-border-radius:5px;
                         -webkit-border-radius:5px; ">

<span class="smalltext">
<strong>Firma de {$post['username']}</strong></span></legend>
 <center>{$post['signature']}</center>
</fieldset>

Una ves que modificamos la plantilla solo debemos cambiar la parte en donde dice background: url(images/tutheme/background.png) por el nombre de la carpeta en la que se encuentre su tema

Despues subimos esta imagen al directorio en donde se encuentre nuestro Theme y listo.


Espero les sea de gran ayuda ya que este es mi primer Tutorial, cualquier duda solo comentelo. Saludos


Archivos Adjuntos

tengo un problema, cuando pongo ese codigo en postbit_signature me sale esto:
<br&nbsp;/>
<fieldset&nbsp;style="background:&nbsp;url(images/tutheme/background.png)&nbsp;repeat;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;border:&nbsp;2px&nbsp;solid&nbsp;#000;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-moz-border-radius:5px;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-webkit-border-radius:5px;">

<legend&nbsp;style="background:&nbsp;url(images/tutheme/background.png)&nbsp;repeat;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;border:&nbsp;1px&nbsp;solid&nbsp;#000;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;padding:4px;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-moz-border-radius:5px;
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;-webkit-border-radius:5px;&nbsp;">

<span&nbsp;class="smalltext">
<strong>Firma&nbsp;de&nbsp;{$post['username']}</strong></span></legend>
&nbsp;<center>{$post['signature']}</center>
</fieldset>&nbsp;
Que hago??
Borra todos los &nbsp, aunque no cambia nada, solo son espacios... en blanco, que HTML los reemplaza por eso...

Edito: Corrección, XHTML utiliza eso, MyBB no usa HTML simple Tongue

Aprieta [Imagen: postbit_quote.gif] eso en el tema y le copias los códigos porque si ,los copias así te saldrán esos &nbsp.
Aunque lo quite no me sale así, me sale Firma Quico y un par de lineas mas abajo mi firma, pero no me sali ni recuadrado ni nada
<br />
<fieldset style="background: url(images/tutheme/background.png) repeat;
                         

<legend style="background: url(images/tutheme/background.png) repeat;
                          

en "tutheme" pusiste el nombre del directorio de tu estilo sierto?

Y pusiste esta imagen XD?:
[Imagen: 2zejnt4.png]
Yo deje la plantilla asi:

<br />
<fieldset style="background: url(images/background.png) repeat;
                          border: 2px solid #000;
                         -moz-border-radius:5px;
                         -webkit-border-radius:5px;">

<legend style="background: url(images/background.png) repeat;
                          border: 1px solid #000;
                          padding:4px;
                         -moz-border-radius:5px;
                         -webkit-border-radius:5px; ">

<span class="smalltext">
<strong>Firma de {$post['username']}</strong></span></legend>
 <center>{$post['signature']}</center>
</fieldset> 

Y guarde la imagen en images.


para no hacer esa edición nomas de un theme. Smile Sino de todos ya nomas añadiendo la plantilla al que lo quiera agregar.
ya me funciono, jeje
(23 Dec, 2010, 4:39 pm)quico escribió: ya me funciono, jeje

Seguro estabas editando com firefox, o google crhome [ ya no recuerdo bien cuadl de los dos da ese problema] uno de los dos al editar te cambia caracteres, no sé porque, pero alguna vez me pasó lo mismo XD


PD: GRACIAS POR EL TUTO!!, está super genial y fácil +10 Big Grin
Muy bueno, integrado en mi foro y da un mayor estilo jeje Big Grin
Colaboradores
zayko yazminwse xRockztar TAito quico Omar G. Maxii InfraWorld Ignnacio Gustavo R. Boreas angeluz -NaKu-
This forum uses Lukasz Tkacz MyBB addons.