[Ayuda]  [PHP] Ayuda con PREG_MATCH
Buenas, necesito ayuda con el PREG_MATCH de AutoMedia. En el plugin de Youtube al poner etiquetas como (align=center)enlace(/align) no me sale el ví...

Buenas, necesito ayuda con el PREG_MATCH de AutoMedia.

En el plugin de Youtube al poner etiquetas como (align=center)enlace(/align) no me sale el vídeo debido a que está la etiqueta pegando a la ruta. En cambio si pongo (align=center) enlace(/align) (con un espacio) sí me deja.

La pregunta es, ¿hay alguna manera de que por detrás del enlace se puedan poner etiquetas?

Porque después del enlace se puede poner la etiqueta que se desee, pero por detrás no.

El código es este:

        if(preg_match('<a href=\"(http://)(?:www\.)?youtube.com/watch\?v=(.{11})">isU',$message))
        {
                $message = preg_replace("#(\[automedia\]|(<a href=\")?(http://)?(www.)?youtube.com/watch\?(.*?)v=)([\w_-]{11})((\[/automedia\]|\" target=\"_blank\">)(.*?)</a>)#i", "<div class=\"am_embed\"><iframe width=\"$w\" height=\"$h\" src=\"http://www.youtube.com/embed/$6?wmode=opaque\" frameborder=\"0\" allowfullscreen></iframe></div>", $message);
        }
Yo creo que si la agregas manualmente funcionará tal ves o igualmente poniendo la alineacion directamente, saludos...

if(preg_match('<a href=\"(http://)(?:www\.)?youtube.com/watch\?v=(.{11})">isU',$message))
        {
                $message = preg_replace("#(\[align=center\]|\[automedia\]|(<a href=\")?(http://)?(www.)?youtube.com/watch\?(.*?)v=)([\w_-]{11})((\[/automedia\][/align\]|\" target=\"_blank\">)(.*?)</a>)#i", "<div class=\"am_embed\"><iframe width=\"$w\" height=\"$h\" src=\"http://www.youtube.com/embed/$6?wmode=opaque\" frameborder=\"0\" allowfullscreen></iframe></div>", $message);
        } 

o la otra sería:

if(preg_match('<a href=\"(http://)(?:www\.)?youtube.com/watch\?v=(.{11})">isU',$message))
        {
                $message = preg_replace("#(\[automedia\]|(<a href=\")?(http://)?(www.)?youtube.com/watch\?(.*?)v=)([\w_-]{11})((\[/automedia\]|\" target=\"_blank\">)(.*?)</a>)#i", "<center><div class=\"am_embed\"><iframe width=\"$w\" height=\"$h\" src=\"http://www.youtube.com/embed/$6?wmode=opaque\" frameborder=\"0\" allowfullscreen></iframe></div></center>", $message);
        } 

Alguna de las dos debiera funcionar, al menos para centrar los videos, pero por separado habría que hacer algunos cambios mas al codigo saludos...
Colaboradores
vlad
This forum uses Lukasz Tkacz MyBB addons.