[Ayuda]  No funciona es MyCode
Web: Localhost Version: 1.6.4 Actualizacion: 1.6.3 -> 1.6.4 Theme: Personalizado Tengo un problema con un mycode spoiler, no funciona, ya intente...

Web: Localhost
Version: 1.6.4
Actualizacion: 1.6.3 -> 1.6.4
Theme: Personalizado

Tengo un problema con un mycode spoiler, no funciona, ya intente todo asta el grado de tener que pedir ayuda (¬¬* xD).

Expresión regular:
\[spoiler\](.*?)\[/spoiler\]

Reemplazar por:
<div class="spoiler">
		<div class="spoiler_cabecera"><button class="button" style="float: right; padding: 0px 5px; font-size: 10px;" onclick="javascript: if(parentNode.parentNode.getElementsByTagName('div')[1].style.display == 'block'){ parentNode.parentNode.getElementsByTagName('div')[1].style.display = 'none'; this.innerHTML='Mostrar contenido'; } else { parentNode.parentNode.getElementsByTagName('div')[1].style.display = 'block'; this.innerHTML='Ocultar contenido'; }">Mostrar contenido</button>Spoiler:</div>
		<div class="spoiler_contenido" style="display: none;">$1</div>
	</div>

Podría alguien probarlo en su localhost para verificar? Creo que mybb 1.6.4 tiene algun problema por alli por que en mi foro 1.6.3 si funcionaba :S
Omar G.
yo digo que es esto <button class="button" style="float: right; padding: 0px 5px; font-size: 10px;" onclick="javascript: if(parentNode.parentNode.getElementsByTagName('div')[1].style.display == 'block'){ parentNode.parentNode.getElementsByTagName('div')[1].style.display = 'none'; this.innerHTML='Mostrar contenido'; } else { parentNode.parentNode.getElementsByTagName('div')[1].style.display = 'block'; this.innerHTML='Ocultar contenido'; }">Mostrar contenido</button>
Ese no sirvió, y solo le quitaste el javascript? Por que si no como funcionaria xD?
Omar G.
Supongo que 'subestime' tu problema, asta yo lo tengo T.T

Si alguien puede ayudar gracias.
Omar G.
No me refiero a que ese codigo te esta ocacionando el problema
Lo raro es que me funcionaba en 1.6.3 pero no en 1.6.4

Pedire soporte en mybb.com por que dejo de funcionar en el foro despues de actualizar, que raro...
Omar G.
dale sama ! estare pendiente tambien en este tema a ver  si te dan solucion Smile

Si no hacemos huelga ¿ ? xD
Revisa bien por que no es la actualizacion

yo actualize y no tuve problemas con jS
Yo actualice dos foros y sin problemas, solo este código spoiler en ambos foros.

Quizás si este mal el código, pero solo es javascript así que no hay rozan para que deje de funcionar y menos si ya funcionaba antes.

De todas formas ya pedí soporte en mybb, reportare cuando me solucionen.
Omar G.
Colaboradores
~ice wasmake Avatares
This forum uses Lukasz Tkacz MyBB addons.